RSS

home


assalamu`alaikum

selamat datang di blog kanak sasak…

blog ini ditulis sebagai media komunikasi antara penulis dan pembaca dimana saja berada…

semoga dengan adanya blog ini, tali silaturrahmi dan persaudaraan kita semakin erat.

penulis juga berharap ada komentar,saran dan kritik dari pengunjung semua demi perkembangan blog ini kedepannya .

masukan-masukan dari pengunjung sangat membantu penulis untuk mengembangkan isi blog in kedepannya, semoga dengan adanya blog ini bisa membantu para pengunjung untuk mendapatkan informasi yang bermanfaat dan yang sedang di butuhkan saat in

semoga lebih bermanfaat lagi untuk kita semua… amin!!!

kunjungi juga blog baru saya http://hadiwijaya.info/

 
2 Komentar

Ditulis oleh pada Agustus 28, 2008 in komputer, Lombok Cyber, tips dan trik, tutorial

 

how to become hacker


Renungkan!! How To Become A Hacker Terjemahan Indonesia dari How To Become A Hacker oleh Eric S. Raymond. Diterjemahkan oleh Steven Haryanto. Pertama diterjemahkan 31 Juli 1999. Update ke revisi 1.7 dan perbaikan terjemahan tanggal 19 Mei 2001. 1. Mengapa Tulisan Ini Dibuat? Sebagai penyunting Jargon File dan penulis beberapa tulisan serupa lain yang telah dikenal luas, saya sering menerima email permintaan dari newbie jaringan yang antusias, bunyinya (kurang lebih) “bagaimana cara menjadi hacker jagoan?”. Anehnya, tidak ada FAQ atau dokumen web lain yang membahas pertanyaan penting ini, jadi inilah tulisan saya. Jika Anda membaca snapshot dokumen ini secara offline, kunjungi versi terakhirnya di http://www.tuxedo.org/~esr/faqs/hacker-howto.html. Catatan: ada daftar FAQ di akhir tulisan. Bacalah FAQ ini — dua kali — sebelum mengirim email pertanyaan pada saya seputar dokumen ini. Terjemahan berbagai bahasa dari tulisan ini tersedia: : Bulgaria, Cina (Simplified), Cina (Tradisional), Denmark, Belanda, Prancis, Finlandia, Jerman, Hungaria, Italia, Indonesia, Jepang, Korea, Portugis, Rusia, Spanyol, dan Swedia. Perhatikan bahwa karena dokumen ini sesekali berubah, terjemahan-terjemahan tersebut mungkin sedikit banyak kadaluarsa. 2. Apa Hacker Itu? Jargon File memuat beberapa definisi untuk kata ‘hacker’, hampir semuanya berkaitan dengan kemahiran teknis serta kegemaran menyelesaikan masalah dan mengatasi keterbatasan. Namun jika ingin menjadi seorang hacker, hanya ada dua definisi yang relevan. Ada sebuah komunitas, budaya, terdiri dari para programer mahir dan ahli jaringan, yang sejarahnya bermula dari dekade minikomputer pertama yang memiliki time-sharing dan zaman eksperimen awal ARPAnet. Dari anggota budaya inilah muncul istilah ‘hacker’. Hackerlah yang membangun internet. Hackerlah yang membuat sistem operasi Unix menjadi seperti sekarang. Hackerlah yang mengoperasikan Usenet. Hacker yang membuat World Wide Web berjalan. Jika Anda bagian dari budaya ini, jika Anda telah menyumbangkan sesuatu untuk budaya ini, dan rekan lain di dalamnya mengenali Anda sebagai seorang hacker, maka seorang hackerlah Anda. Cara pikir hacker tidak terbatas pada budaya hacker software. Ada orang yang menerapkan sikap hacker pada banyak bidang lain, elektronik atau musik — bahkan, cara pikir hacker ada di tingkat tertinggi setiap bidang ilmu dan seni. Hacker software mengakui semangat serupa ini dan kadang menyebut orang-orang tersebut “hacker” pula — sebagian juga berpendapat bahwa sifat seorang hacker tidak bergantung pada wadah tempatnya bekerja. Tapi, untuk selanjutnya, kita akan memusatkan perhatian pada software hacker, keahlian dan sikap mereka, serta tradisi budaya bersama yang melahirkan istilah ‘hacker’. Terdapat pula sekelompok lain yang menyebut-nyebut diri hacker, padahal bukan. Mereka-mereka ini (terutama terdiri dari remaja pria) mendapat kepuasan lewat membobol komputer dan mengakali telepon (phreaking). Hacker sejati menyebut orang-orang ini ‘cracker’ dan tidak suka bergaul dengan mereka. Hacker sejati memandang cracker sebagai orang malas, tidak bertanggung jawab, dan tidak terlalu cerdas. Hacker sejati tidak setuju jika dikatakan bahwa dengan menerobos keamanan seseorang telah menjadi hacker, sama seperti jika dikatakan bahwa mengontakkan mobil membuat seseorang langsung menjadi ahli mesin. Sayangnya, wartawan dan penulis telah salah kaprah dan menggunakan kata ‘hacker’ untuk melukiskan cracker; sesuatu yang selalu membuat kesal para hacker sejati. Perbedaan mendasar antara hacker dan cracker : hacker membangun, cracker membongkar (dan biasanya cenderung merusak). Jika Anda ingin menjadi hacker, lanjutkan membaca. Jika ingin menjadi cracker, kunjungi newsgroup alt.2600 dan bersiaplah menghabiskan lima sampai sepuluh tahun di balik jeruji setelah mengetahui bahwa Anda ternyata tidak sepandai yang Anda kira. Hanya itu yang perlu dikatakan tentang cracker. 3. Sikap Hacker Pekerjaan hacker menyelesaikan masalah dan membangun sesuatu, dan hacker percaya pada kebebasan dan kerjasama sukarela. Agar dapat diterima sebagai seorang hacker, Anda harus berbuat seolah-olah Anda memiliki sikap ini. Dan agar dapat berbuat demikian, sikap ini harus benar-benar diyakini. Tapi kalau Anda berniat menumbuhkan sikap ini hanya agar dapat diterima di lingkungan hacker, maka Anda belum menangkap maknanya. Menjadi orang yang meyakini sikap hacker penting bagi Anda sendiri — agar bisa terus belajar dan termotivasi. Sama seperti semua seni kreatif lain, cara paling efektif untuk menjadi seorang ahli adalah dengan meniru cara berpikir ahli-ahli lainnya — bukan hanya secara intelektual tapi juga emosional. Seperti diungkapkan oleh sebuah sajak Zen modern di bawah: Untuk mengikuti jalan: pandanglah sang ahli, ikuti sang ahli, berjalan bersama sang ahli, kenali sang ahli, jadilah sang ahli. Jadi, jika ingin menjadi hacker, ulangi pernyataan di bawah ini sampai benar-benar Anda yakini: 3.1 Dunia penuh dengan persoalan-persoalan menarik yang menanti untuk dipecahkan. Menjadi seorang hacker sebetulnya menyenangkan, tapi ‘menyenangkan’ yang menuntut usaha. Usaha ini membutuhkan motivasi. Atlet yang sukses memperoleh motivasi dari kepuasan fisik saat tubuh mereka beraksi, saat mendorong diri melampaui batasan fisik. Demikian juga, untuk menjadi seorang hacker Anda harus merasa tertarik memecahkan persoalan, mengasah keahlian, dan melatih kecerdasan. Jika Anda merasa bukan seperti ini secara naluri, Anda harus berusaha menjadi demikian jika ingin berhasil menjadi hacker. Jika tidak, energi hacking Anda akan melemah karena perhatian teralihkan oleh seks, uang, dan kedudukan. (Anda pun harus mengembangkan keyakinan pada kapasitas belajar diri — keyakinan bahwa meskipun yang Anda ketahui belum cukup untuk memecahkan suatu persoalan, jika satu potongan saja dari persoalan Anda usaha pecahkan, maka itu sudah cukup memberi pelajaran kepada Anda untuk menyelesaikan potongan berikutnya — dan berikutnya, hingga semua potongan terselesaikan.) 3.2 Tidak seharusnya masalah yang sama dipecahkan dua kali. Otak yang kreatif merupakan sumber daya yang berharga dan terbatas. Tidak seharusnya sumber daya ini diboroskan hanya untuk memikirkan kembali suatu persoalan dari dasar; padahal ada begitu banyak masalah menarik baru lain di dunia ini yang menanti. Agar dapat bertingkah laku seperti hacker, Anda harus percaya bahwa waktu berpikir hacker lain itu berharga — sebegitu berharganya hingga merupakan suatu kewajiban moral bagi Anda untuk membagikan informasi, menyelesaikan masalah lalu memberi jawabannya pada hacker lain supaya mereka menyelesaikan masalah baru dan tidak selamanya berkutat pada masalah-masalah lama. (Tidak harus berkeyakinan bahwa semua produk kreatif Anda harus direlakan bagi orang lain, meski hacker yang demikianlah yang paling dihormati hacker lain. Menurut nilai-nilai hacker, jual saja sebagian asal cukup untuk tetap makan, tetap dapat membayar sewa rumah, dan tetap dapat memakai komputer. Tidak melanggar nilai hacker jika Anda memanfaatkan ilmu Anda untuk membiayai keluarga atau bahkan memperkaya diri, asalkan sambil melakukannya tetap setia pada disiplin ilmu dan sesama hacker lain.) 3.3 Kebosanan dan pekerjaan membosankan itu jahat. Hacker (dan manusia kreatif pada umumnya) tidak seharusnya dibosankan dengan pekerjaan bodoh yang berulang-ulang, karena ini berarti mereka tidak melakukan pekerjaan yang hanya bisa dilakukan oleh mereka — menyelesaikan persoalan-persoalan baru. Pemborosan sumber daya ini merugikan semua pihak. Karena itu kebosanan dan pekerjaan membosankan bukan saja tidak menyenangkan tapi juga jahat. Agar dapat bertingkah laku seperti hacker, Anda harus meyakini hal ini sehingga Anda berkeinginan untuk mengotomasi sebanyak mungkin bagian yang membosankan, bukan saja bagi diri sendiri tapi juga orang lain (terutama sesama hacker). (Ada satu kekecualian yang jelas. Hacker kadang melakukan pekerjaan yang di mata orang lain tampaknya berulang-ulang atau membosankan, ini untuk latihan menjernihkan pikiran, atau dalam rangka memperoleh keahlian atau pengalaman yang tak bisa tidak harus diperoleh dengan cara demikian. Tentu saja hal ini dilakukan atas dasar kehendaknya sendiri — setiap orang yang mampu berpikir tidak seharusnya dipaksa menjadi bosan.) 3.4 Kebebasan itu baik.[/b Secara alamiah hacker itu anti-otoriter. Siapa pun yang dapat memerintah. Anda akan dapat menghentikan Anda untuk menyelesaikan persoalan yang menarik — dan, sesuai pikiran otak para otoriter, pada umumnya akan membuat alasan yang benar-benar bodoh untuk itu. Jadi sikap otoriter harus dilawan di mana pun Anda berada, agar nantinya tidak menekan Anda dan hacker-hacker lain. (Tidak untuk disamakan dengan melawan setiap bentuk kekuasaan. Anak-anak tetap harus dibimbing, para kriminal ditahan. Seorang hacker mungkin akan tunduk pada bentuk-bentuk kekuasaan tertentu agar dapat memperoleh sesuatu yang lebih dari waktu yang dibutuhkan untuk mengikuti peraturan. Ini lebih merupakan tawar-menawar yang terbatas dan dilakukan secara sadar, jenis tunduk diri yang diinginkan oleh orang-orang otoriter tentu saja tidak bisa diterima.) Para otoriter hidup di atas sensor dan kerahasiaan. Mereka tidak percaya pada kerjasama dan berbagi informasi — satu-satunya jenis ‘kerja sama’ yang disukai adalah yang dapat mereka kendalikan. Jadi untuk berlaku seperti seorang hacker, Anda perlu mengembangkan rasa benci pada penyensoran, kerahasiaan, dan penggunaan kekerasan atau penipuan untuk memaksakan kehendak pada orang dewasa. Dan Anda harus bersedia bertindak atas dasar keyakinan ini. [b]3.5 Sikap saja tak ada artinya tanpa keahlian. Untuk menjadi hacker, Anda perlu mengembangkan sebagian dari sikap-sikap yang telah disebutkan. Tapi memiliki sikap saja belum membuat seseorang menjadi hacker, atau atlet juara atau bintang rock. Untuk menjadi hacker dibutuhkan kecerdasan, latihan, dedikasi, dan kerja keras. Jadi, Anda perlu belajar untuk tidak mempercayai sikap saja dan menghormati setiap bentuk kemampuan. Hacker tidak bersedia menghabiskan waktu dengan orang-orang yang hanya bersikap seperti hacker, tapi hacker memuja keahlian — terutama keahlian dalam hacking, tapi juga keahlian di bidang apapun. Yang terlebih bagus lagi yaitu keahlian dalam bidang yang sulit dan hanya dapat dikuasai oleh sedikit orang, dan yang terbaik adalah keahlian dalam bidang yang sulit dan melibatkan ketajaman mental, keahlian, serta konsentrasi. Bila Anda memuja keahlian, Anda akan merasa senang dalam meningkatkan kemampuan diri — kerja keras dan dedikasi akan menjadi semacam permainan yang mengasyikkan ketimbang pekerjaan membosankan. Dan hal ini penting dalam proses menjadi hacker. 4. Kemampuan Hacking Dasar Sikap hacker penting, tapi terlebih penting lagi keahlian. Sikap bukan pengganti keahlian, dan ada seperangkat keahlian menggunakan perangkat tool yang perlu Anda kuasai sebelum orang bahkan bisa berpikir memanggil Anda hacker. Perangkat tool ini perlahan-lahan memang berubah seiring teknologi yang menciptakan keahlian baru dan membuat keahlian lama tidak berguna. Misalnya, dulu keahlian pemrograman bahasa mesin termasuk, dan kemampuan HTML belum dan hanya baru-baru ini saja. Yang jelas saat ini yang termasuk adalah: 4.1 Pelajari pemrograman. Ini tentunya merupakan keahlian hacking yang fundamental. Jika Anda belum pernah belajar bahasa pemrograman mana pun, saya sarankan mulai dengan Python. Disainnya bersih, terdokumentasi dengan baik, dan cukup mudah bagi pemula. Meski menjadi bahasa pertama, bukan berarti Python hanya mainan, Python amat ampuh dan fleksibel dan cocok untuk proyek-proyek besar. Saya menulis evaluasi terhadap Python yang lebih mendetil. Tutorial Python bisa dilihat di situs web Python (terjemahan Indonesia). Java juga bahasa yang baik untuk belajar pemrograman. Lebih sulit dari Python, tapi menghasilkan kode yang lebih cepat dari Python. Menurut saya Java amat bagus sebagai bahasa kedua. Perlu diingat bahwa dengan satu dua bahasa pemrograman saja Anda tidak akan mencapai tingkat keahlian seorang hacker, atau bahkan seorang programer — Anda perlu belajar cara memandang pemrograman secara umum, tidak bergantung pada satu bahasa mana pun. Untuk menjadi hacker sejati, Anda perlu mencapai tahap di mana Anda dapat mempelajari bahasa baru dalam beberapa hari, dengan menghubungkan apa yang ada di manual dengan apa yang telah Anda ketahui. Hal ini berarti, Anda perlu mempelajari beberapa bahasa yang jauh berbeda satu dengan yang lainnya. Jika ingin serius dalam pemrograman, pada akhirnya Anda harus belajar C, bahasa inti sistem operasi Unix. C++ terkait erat dengan C; jika tahu yang satu, belajar yang lain tidak akan susah. Namun keduanya bukan bahasa yang cocok untuk dipelajari pertama kali. Bahasa lain yang juga penting untuk hacker antara lain Perl dan LISP. Perl patut dipelajari untuk kebutuhan praktis; Perl dipakai secara amat meluas untuk halaman web aktif dan untuk administrasi sistem, jadi meskipun nantinya Anda tidak akan membuat program dalam Perl, Anda sebaiknya belajar cara membaca Perl. LISP patut dipelajari karena akan memberikan pengalaman ‘membuka pikiran’ jika Anda telah menangkapnya, dengan mempelajari LISP, Anda akan menjadi seorang programer yang lebih baik, meskipun dalam kenyataan Anda akan jarang memakainya. Paling baik sebetulnya mempelajari semuanya (Python, Java, C/C++, Perl, dan LISP). Selain merupakan bahasa-bahasa terpenting dalam hacking, masing-masing mewakili cara pendekatan pemrograman yang berbeda, dan tiap bahasa akan memberi Anda pelajaran-pelajaran berharga. Tentu saja, di sini tidak mungkin saya memberi petunjuk lengkap cara memrogram — pemrograman merupakan keahlian yang kompleks. Tapi, satu petunjuk yang saya berikan: buku dan kursus saja tidak akan membuat Anda menjadi seorang programer (banyak, mungkin hampir semua hacker terbaik itu belajar mandiri). Anda akan menjadi programer dengan (a) membaca kode dan (b) menulis kode. Belajar membuat program adalah seperti belajar menulis dalam bahasa alamiah. Cara terbaik untuk melakukannya dengan membaca tulisan yang dibuat oleh para ahlinya, membuat tulisan sendiri sedikit, membaca lebih banyak lagi, menulis lebih banyak, dan mengulanginya sampai di tulisan Anda mulai terbentuk semacam kekuatan dan kemahiran penggunaan kata seperti di tulisan-tulisan yang semula Anda teladani. Dahulu sulit mencari kode yang baik untuk dibaca, karena dulu hanya sedikit program-program besar yang terdapat dalam bentuk source untuk bisa dibaca dan diutak-atik hacker-hacker pemula. Sekarang kondisinya jauh berbeda: software open-source, tool pemrograman, dan sistem operasi (semua dibuat oleh hacker) kini banyak terdapat. Dan ini mengantar kita pada poin berikutnya… 4.2 Cari, pelajari, dan jalankan salah satu versi Unix open-source. Saya anggap Anda memiliki, atau memperoleh akses ke komputer pribadi (anak-anak sekarang mudah sekali mendapatkan akses 🙂 ). Kalau ada satu langkah terpenting bagi pemula untuk mendapatkan kemampuan hacker, itu adalah mendapatkan satu salinan sistem operasi Linux atau salah satu Unix BSD, meng-install-nya di komputer sendiri, dan menjalankannya. (Tidak saya sarankan meng-install Linux sendirian jika Anda pemula. Cari klub komputer atau kelompok pengguna Linux di daerah Anda dan mintalah bantuan; atau hubungi Linux Internet Support Co-Operative. LISC mengurus channel-channel IRC tempat Anda dapat bertanya). Tentu, di dunia ini ada banyak sistem operasi selain Unix. Tapi sistem-sistem operasi tersebut didistribusikan dalam program jadi (binary) — kodenya tidak bisa Anda baca, sehingga sistem operasi tersebut tidak bisa Anda modifikasi. Belajar hacking di DOS atau Windows atau MacOS adalah bagaikan belajar menari dengan seluruh tubuh digips. Lagipula Unix-lah sistem operasi Internet. Meski tentu bisa belajar menggunakan internet tanpa mengenal Unix, Anda tak akan mampu menjadi hacker Internet tanpa memahami Unix. Untuk alasan inilah, budaya hacker saat ini cukup cenderung berat ke Unix. (Ini tidak selalu benar, beberapa hacker zaman dahulu tidak menyukai kenyataan ini, tapi simbiosis antara Unix dan Internet telah menjadi kuat sehingga bahkan otot Microsoft pun tak mampu membengkokkannya.) Jadi, buatlah sistem Unix — saya pribadi menyukai Linux tapi tentu saja ada yang lainnya (dan ya, Anda bisa menjalankan Linux dan DOS/Windows di mesin yang sama). Pelajari Unix. Jalankan Unix. Bermain-mainlah dengan Unix. Berhubungan dengan internet melalui Unix. Baca kodenya. Modifikasi. Di Unix Anda akan menjumpai tool pemrograman yang lebih baik (termasuk C, Lisp, Python, dan Perl) ketimbang di sistem operasi Microsoft manapun, Anda akan bersenang-senang, dan Anda akan mendapat pengetahuan lebih dari yang Anda sadari sampai kemudian ketika mengenang kembali Anda telah seorang hacker ahli. Lebih jauh tentang mempelajari Unix, lihat The Loginataka. Untuk memperoleh Linux, lihat Where can I get Linux. Bantuan dan resource BSD Unix bisa Anda lihat di http://www.bsd.org. Saya menulis pengantar dasar Unix dan Internet. (Catatan: Saya tidak menganjurkan menginstal Linux atau BSD sendirian jika Anda seorang pemula. Untuk Linux, carilah sebuah kelompok pengguna lokal Linux [KPLI di Indonesia] dan mintalah bantuan mereka; atau hubungi Open Projects Network. LISC memaintain daftar IRC channel yang bisa Anda datangi untuk memperoleh bantuan.) 4.3 Pelajari cara menggunakan World Wide Web dan cara menulis HTML. Kebanyakan hasil budaya hacker bekerja di belakang layar tanpa diketahui orang banyak, membantu mengoperasikan pabrik, kantor, dan universitas, tanpa ada pengaruh yang jelas pada cara hidup para non-hacker. Web adalah satu kekecualian, bahkan para politisi pun mengakui bahwa barang mainan hacker yang besar dan berkilauan ini telah mengubah dunia. Untuk satu alasan ini saja (dan juga banyak alasan bagus lainnya) Anda perlu mempelajari cara pengoperasian Web. Maksudnya lebih dari sekedar cara menggunakan browser (sebab kalau itu siapa pun bisa), tapi mempelajari cara menulis HTML, bahasa markup Web. Bila Anda belum menguasai pemrograman, lewat menulis HTML Anda akan diajari beberapa kebiasaan mental yang akan membantu Anda belajar pemrograman. Jadi, buatlah home page. Hanya dengan membuat homepage tidak akan membuat Anda menjadi (bahkan dekat pun tidak) seorang hacker. Web penuh dengan home page. Kebanyakan hanyalah kotoran tanpa arti, tanpa isi — kotoran yang tampak indah, tapi tetap kotoran (lebih jauh tentang ini, lihat The HTML Hell Page). Agar bermanfaat, halaman Anda harus mengandung content — harus menarik dan/atau berguna bagi hacker lain. Dan ini mengantar kita pada bahasan berikutnya… 5. Status dalam Budaya Hacker Seperti halnya dalam kebanyakan budaya lain tanpa ekonomi uang, dunia hacker berjalan di atas reputasi. Anda berusaha menyelesaikan persoalan-persoalan menarik, tapi seberapa menarik persoalan tersebut, dan apakah solusi Anda benar-benar baik, merupakan sesuatu yang umumnya hanya dapat dinilai oleh rekan sejawat atau atasan Anda. Demikian juga, dalam permainan hacker, Anda menjaga nilai terutama lewat pandangan hacker lain terhadap kemampuan Anda (inilah sebabnya Anda belum benar-benar seorang hacker sampai hacker-hacker lain dengan konsisten menyebut Anda seorang hacker). Kenyataan ini dikaburkan oleh citra hacking sebagai pekerjaan menyendiri; juga oleh tabu budaya hacker (yang kini perlahan-lahan menghilang namun masih tetap kuat) yang tidak mengakui bahwa ego atau pengesahan dari luar berpengaruh pada motivasi seseorang. Tegasnya, dunia hacker merupakan apa yang disebut oleh para antropolog sebagai budaya memberi. Kedudukan dan reputasi tidak diperoleh dengan menguasai orang lain, atau dengan menjadi seseorang yang cantik, atau denganmemiliki sesuatu yang tidak dimiliki orang lain, tapi dengan memberikan sesuatu. Tepatnya, dengan memberikan waktu Anda, kreativitas, dan hasil dari kemampuan Anda. Pada dasarnya ada lima hal yang bisa dilakukan agar dihormati oleh hacker: 5.1 Menulis software open-source. Yang pertama (yang paling inti dan paling tradisional) adalah menulis program yang dipandang berguna atau mengasyikkan oleh hacker lain, kemudian memberikan source programnya untuk digunakan oleh seluruh budaya hacker. (Dulu karya semacam ini disebut ‘software bebas’ (free software), tapi istilah ini memusingkan banyak orang karena mereka tidak tahu apa arti tepat dari ‘free’. Sekarang banyak yang lebih menyukai istilah ‘software open-source‘.) Para dewa1 yang dipuja di dunia hacker yaitu mereka yang telah menulis program besar yang berkemampuan tinggi dan dibutuhkan di mana-mana, lalu memberikan program ini cuma-cuma, dan sekarang program itu telah dipakai setiap orang. 5.2 Membantu menguji dan men-debug software open-source Yang selanjutnya berjasa adalah mereka yang bertahan menggunakan dan men-debug software open-source. Di dunia yang tak sempurna ini, tanpa terhindarkan kita harus menghabiskan sebagian besar waktu pengembangan software dalam tahap debugging. Karena itu setiap penulis software open-source yang waras akan berpendapat bahwa penguji beta yang baik (yang tahu bagaimana menjelaskan gejala masalah dengan jelas, bagaimana melokalisir masalah, mampu mentolerir bug di rilis cepat, dan bersedia menjalankan beberapa rutin diagnostik sederhana) itu amat sangat berharga. Bahkan satu saja penguji beta sudah mampu membantu menjadikan tahap debugging dari mimpi buruk panjang yang melelahkan menjadi hanya gangguan yang justru menyehatkan. Bila Anda seorang pemula, cobalah mencari program yang sedang dalam tahap pengembangan, yang menarik bagi Anda, dan jadilah seorang penguji beta yang baik. Dari sini Anda secara alamiah akan meningkat dari membantu menguji program ke membantu memodifikasi program. Anda akan belajar banyak, dan pada gilirannya nanti Anda pun akan memperoleh bantuan dari orang lain saat membutuhkan. 5.3 Menerbitkan informasi yang bermanfaat. Yang bagus juga untuk dilakukan yaitu mengumpulkan dan menyaring informasi-informasi menarik dan berguna ke dalam halaman Web atau dokumen seperti FAQ (Frequently Asked Questions — daftar jawaban pertanyaan-pertanyaan yang sering diajukan orang), dan membuat dokumen-dokumen ini mudah didapat orang. Pemelihara FAQ teknis yang besar-besar juga mendapatkan hormat hampir seperti para penulis software open-source. 5.4 Membantu terus berjalannya infrastruktur. Budaya hacker (dan juga dalam hal ini pengembangan rekayasa Internet) dijalankan oleh relawan. Banyak sekali pekerjaan yang dibutuhkan namun bukan pekerjaan yang agung, yang harus dilakukan agar semuanya tetap berjalan – melakukan administrasi mailing list, moderasi newsgroup, memelihara situs archive software yang besar, mengembangkan dokumen-dokumen RFC serta standar teknis lainnya. Mereka yang melakukan hal-hal seperti dengan baik juga dihormati, karena orang tahu bahwa pekerjaan seperti ini menghabiskan banyak waktu dan kalah mengasyikkan dibanding bermain dengan kode. Melakukan pekerjaan seperti ini menunjukkan bahwa seseorang memiliki dedikasi. 5.5 Mengabdi kepada budaya hacker itu sendiri. Terakhir, Anda dapat mengabdi dan menyebarluaskan budaya hacker (lewat, misalnya, menulis panduan tepat bagi pemula tentang cara menjadi seorang hacker 🙂 ). Anda tidak bisa melakukan hal ini kecuali telah berkecimpung cukup lama dan menjadi figur yang cukup terkenal di salah satu dari empat hal sebelumnya. Budaya hacker tidak persis memiliki pemimpin, tapi memiliki pahlawan, tetua suku, sejarawan, dan para jubir. Jika Anda telah cukup lama berada di ‘medan tempur’, Anda dapat saja memperoleh salah satu dari jabatan-jabatan ini. Peringatan: hacker tidak mempercayai ego tetua suku yang terlampau mencolok, jadi berbahaya jika Anda terlalu terlihat untuk berusaha menjadi terkenal. Cara yang benar seharusnya yaitu dengan memposisikan diri sedemikian rupa sehingga jabatan tersebut jelas telah Anda capai, lalu kemudian bersikap rendah hati dan ramah sehubungan dengan kedudukan Anda tersebut. 6. Hubungan Hacker/Orang Nyentrik2 Bertentangan dengan mitos populer, tidak perlu menjadi orang nyentrik untuk menjadi hacker. Meski itu sebetulnya membantu, dan pada kenyataannya banyak hacker yang merupakan orang nyentrik. Menjadi orang yang tersisih secara sosial membantu Anda tetap memusatkan perhatian pada hal-hal yang benar-benar penting, seperti berpikir dan hacking. Karena alasan ini, banyak hacker mengadopsi label ‘nerd’ dan bahkan menggunakan istilah yang lebih kasar ‘geek’ sebagai lencana kebanggaan — cara memproklamasikan kebebasan dari tuntutan sosial. Lihatlah The Geek Page untuk pembahasan menyeluruh. Bila Anda tetap dapat memusatkan perhatian pada hacking sampai menjadi cukup ahli dan tetap memiliki kegiatan sosial, itu sah-sah saja. Hal ini memang lebih mudah dilakukan sekarang ketimbang waktu saya seorang pemula di tahun 1970-an; budaya mainstream saat ini jauh lebih ramah pada para techno-nerd. Malah kini semakin banyak orang yang menyadari bahwa hacker kadang merupakan kekasih yang berkualitas dan calon pasangan hidup potensial. Lebih lanjut tentang hal ini, lihat Girl’s Guide to Geek Guys. Bila ketertarikan Anda pada hacking adalah karena Anda tidak mempunyai kegiatan lain, itu juga tidak apa-apa — setidaknya tidak perlu susah-susah memusatkan perhatian. Mudah-mudahan satu hari nanti Anda akan memperoleh kehidupan sosial. 7. Panduan Gaya Saya ulangi, untuk menjadi hacker, Anda perlu memasuki cara pikir hacker. Hal-hal tertentu yang Anda lakukan saat jauh dari komputer kadang membantu mencapainya. Tentu saja kegiatan-kegiatan ini bukan sebagai pengganti hacking (tak ada yang dapat menggantikan hacking) tapi banyak hacker melakukannya, dan merasa bahwa kegiatan tersebut secara dasar berhubungan dengan intisari hacking. * Membaca karya fiksi ilmiah. Datang ke pertemuan fiksi ilmiah (salah satu jalan yang bagus untukbertemu hacker dan proto-hacker). * Mempelajari Zen, dan/atau berlatih bela diri. (Disiplin mental yang diajarkan serupa dengan hacking dalam hal-hal penting.) * Mengasah pendengaran musik.Belajar menghargai jenis-jenis musik yang tidak lazim. Belajar menjadi ahli dalam bermain alat musik tertentu, atau berlatih bernyanyi. * Mengembangkan apresiasi akan permainan kata. * Belajar menulis dalam bahasa asli (Sejumlah banyak hacker, termasuk semua hacker terbaik yang saya kenal, adalah penulis yang cakap). Semakin banyak dari hal-hal di atas yang sudah Anda kerjakan, semakin besar kemungkinan Anda adalah calon hacker berbakat. Kenapa hal-hal di atas yang berhubungan dengan hacking tidak sepenuhnya jelas, tapi semuanya berkaitan dengan gabungan kemampuan otak kiri dan kanan yang penting (hacker harus dapat berpikir logis dan juga sewaktu-waktu harus dapat melangkah keluar dari logika umum suatu permasalahan). Terakhir, sebagian dari hal-hal yang tidak sebaiknya dilakukan: * Jangan menggunakan ID atau nama samaran yang konyol atau berlebihan. * Jangan terlibat perang flame di Usenet (atau di mana pun). * Jangan menggelari diri ‘cyberpunk’, jangan berurusan dengan para ‘cyberpunk’. * Jangan mengirim posting atau email yang penuh salah ketik dan bertata bahasa buruk. Satu-satunya reputasi yang akan Anda dapatkan jika melakukan hal-hal di atas adalah sebagai orang dungu. Ingatan hacker biasanya bagus — mungkin dibutuhkan bertahun-tahun lamanya sebelum Anda dapat diterima kembali. 8. Bacaan Lain Peter Seebach mengurus dokumen bagus Hacker FAQ bagi para manajer yang tidak tahu bagaimana harus berhadapan dengan para hacker. Di Loginataka terdapat beberapa keterangan tentang latihan dan cara bersikap seorang hacker Unix yang benar. Saya juga menulis A Brief History Of Hackerdom. Saya menulis sebuah paper, The Cathedral and the Bazaar, yang menjelaskan banyak tentang cara kerja Linux dan budaya open-source. Topik ini saya bahas lebih tegas dalam kelanjutan paper tersebut, Homesteading the Noosphere. Rick Moen menulis dokumen yang bagus tentang cara mengoperasikan kelompok pengguna Linux. 9. Tanya Jawab (FAQ) T: Maukah Anda mengajari saya cara hacking? J: Sejak pertama kali halaman ini diterbitkan online, setiap minggu (kadang setiap hari) saya mendapatkan beberapa permintaan dari orang agar saya ‘mengajari hacking dari A-Z’. Sayangnya, saya tidak memiliki waktu atau tenaga untuk ini; proyek-proyek hacking saya telah menghabiskan 110% dari waktu saya. Meski toh saya ajarkan, hacking adalah sikap dan kemampuan yang pada dasarnya harus dipelajari sendiri. Anda akan menyadari bahwa meskipun para hacker sejati bersedia membantu, mereka tidak akan menghargai Anda jika Anda minta disuapi segala hal yang mereka ketahui. Pelajari dulu sedikit hal. Tunjukkan bahwa Anda telah berusaha, bahwa Anda mampu belajar mandiri. Barulah ajukan pertanyaan-pertanyaan spesifik pada hacker yang Anda jumpai. Jika toh Anda mengirim email pada seorang hacker untuk meminta nasihat, ketahuilah dahulu dua hal. Pertama, kami telah menemukan bahwa orang-orang yang malas dan sembrono dalam menulis biasanya terlalu malas dan sembrono dalam berpikir sehingga tidak cocok menjadi hacker — karena itu usahakanlah mengeja dengan benar, dan gunakan tata bahaas dan tanda baca yang baik, atau Anda tidak akan diacuhkan. Kedua, jangan berani-berani meminta agar jawaban dikirim ke alamat email lain yang berbeda dari alamat tempat Anda mengirim email; kami menemukan orang-orang ini biasanya pencuri yang memakai account curian, dan kami tidak berminat menghargai pencuri. T: Jadi bagaimana cara memulai? J: Cara terbaik adalah barangkali mengunjungi pertemuan KPLI (kelompok pengguna Linux) setempat. Anda dapat menemukan kelompok yang dimaksud di LDP General Linux Information Page; mungkin ada satu yang di dekat Anda, kemungkinan terkait dengan sebuah sekolah atau universitas. Anggota KPLI kemungkinan akan memberi Anda Linux jika Anda meminta, dan sudah pasti akan menolong Anda menginstall Linux dan mulai memakainya. T: Kapan saya harus mulai? Apakah sudah terlambat? J: Di usia mana pun saat Anda mulai termotivasi, itu usia yang baik. Kebanyakan orang mulai tertarik di usia 15 s.d. 20, tapi banyak perkecualian (lebih tua maupun lebih muda). T: Berapa lama waktu yang dibutuhkan untuk belajar hacking? J: Bergantung seberapa besar bakat dan usaha Anda. Kebanyakan orang memperoleh keahlian yang cukup dalam delapan belas bulan atau dua tahun, jika mereka berkonsentrasi. Tapi jangan pikir setelah itu selesai; jika Anda hacker sejati, Anda akan menghabiskan sisa waktu belajar dan menyempurnakan keahlian. T: Apakah Visual Basic atau Delphi bahasa permulaan yang bagus? J: Tidak, karena mereka tidak portabel. Belum ada implementasi open-source dari bahasa-bahasa ini, jadi Anda akan terkurung di platform yang dipilih oleh vendor. Menerima situasi monopoli seperti itu bukanlah cara hacker. Visual Basic amat jelek. Fakta bahwa bahasa ini proprietary dari Microsoft sudah cukup untuk mendiskualifikasikannya, dan seperti halnya Basic-Basic yang lain, bahasa ini didisain dengan jelek dan akan mengajarkan kepada Anda kebiasaan-kebiasaan memrogram yang jelek. T: Maukah Anda membantu saya meng-crack sistem ini, atau mengajari saya cara cracking? J: Tidak. Jika orang masih mengajukan pertanyaan bodoh seperti di atas setelah membaca tulisan ini, berarti dia terlalu bodoh untuk dididik, meskipun saya memiliki waktu untuk mendidiknya. Setiap email kepada saya dengan permintaan semacam ini akan diabaikan atau dijawab dengan amat kasar. T: Bagaimana cara mendapatkan password account orang lain? J: Ini cracking. Pergi sana, bodoh. T: Bagaimana cara menembus/membaca/memonitor email orang lain? J: Ini cracking. Jauh-jauh sana, goblok. T: Bagaimana cara mencuri privilege op chanel di IRC? J: Ini cracking. Enyah kau, cretin. (Catatan: lihat Jargon File). T: Saya dicrack. Maukah Anda menolong saya mencegah serangan berikutnya? J: Tidak. Setiap kali saya ditanya pertanyaan di atas sejauh ini, ternyata penanyanya seseorang yang menggunakan Microsoft Windows. Tidak mungkin secara efektif melindungi sistem Windows dari serangan crack; kode dan arsitektur Windows terlalu banyak mengandung cacat, sehingga berusaha mengamankan Windows seperti berusaha menyelamatkan kapal yang bocor dengan saringan. Satu-satunya cara pencegahan yang andal adalah berpindah ke Linux atau sistem operasi lain yang setidaknya dirancang untuk keamanan. T: Saya mengalami masalah dengan software Windows saya. Maukah Anda menolong? J: Ya. Buka DOS prompt dengan ketikkan “format c:”. Semua masalah yang Anda alami akan lenyap dalam beberapa menit. T: Di mana tempat untuk bertemu dengan para hacker asli dan mengobrol dengan mereka? Jalan terbaik yaitu dengan mencari kelompok pengguna Unix atau Linux di daerah Anda dan pergi ke pertemuan rutin mereka (sebagian daftar kelompok pengguna ini bisa dilihat di halaman LDP di Sunsite). (Dulu saya pernah berkata bahwa di IRC Anda tidak akan berjumpa dengan hacker sejati, tapi sekarang saya mengerti bahwa kenyataan ini telah berubah. Nampaknya komunitas para hacker sejati, yang berhubungan dengan hal-hal seperti GIMP dan Perl, telah memiliki channel IRC masing-masing). T: Bisakah Anda menganjurkan buku-buku yang berguna seputar hacking? J: Saya memaintain Linux Reading List HOWTO yang mungkin berguna bagi Anda. Loginataka juga barangkali menarik buat Anda. T: Apakah matematika saya harus bagus untuk menjadi hacker? ***J: Tidak. Meskipun Anda perlu dapat berpikir logis dan mengikuti ranpemikiran eksak, hacking hanya menggunakan sedikit sekali matematika formal atau aritmetika. Anda terutama tidak perlu kalkulus atau analisis (kita serahkan itu kepada para insinyur elektro 🙂 ). Sejumlah dasar di matematika finit (termasuk aljabar Bool, teori himpunan hingga, kombinasi, dan teori graph) berguna. T: Bahasa apa yang pertama-tama harus saya pelajari? J: HTML, bila Anda belum menguasainya. Ada banyak buku HTML yang jelek, dengan sampul mengkilap dan penuh dengan kata-kata berlebih, sementara amat disayangkan jumlah buku yang bagus sedikit. Satu yang paling saya sukai yaitu HTML: The Definitive Guide. Tapi HTML bukan bahasa pemrograman penuh. Bila Anda telah siap untuk memrogram, saya sarankan mulai dengan Python. Anda akan mendengar banyak orang menyarankan Perl, dan Perl saat ini masih lebih populer ketimbang Python, tapi Perl lebih sulit dipelajari. C amat penting, tapi juga jauh lebih sulit daripada Python atau Perl. Jangan langsung belajar C untuk pertama kali. T: Hardware seperti apa yang saya butuhkan? J: Komputer pribadi (PC, personal computer) dulu kurang memiliki daya komputasi dan memori sedikit, sehingga membatasi proses belajar hacker. Sudah agak lama kenyataannya tidak lagi demikian. Setiap mesin mulai dari 486DX50 ke atas sudah lebih dari cukup untuk development, X, dan komunikasi Internet, dan harddisk terkecil yang bisa Anda beli sekarang sudah cukup besar. Yang penting dalam memilih hardware adalah apakah kompatibel dengan Linux (atau BSD, jika Anda memilih OS itu). Lagi-lagi, hardware modern kebanyakan kompatibel; yang masih kurang banyak kompatibel adalah modem dan printer; beberapa mesin mengandung hardware yang spesifik Windows dan tidak akan bekerja dengan Linux. Ada FAQ tentang kompatibilitas hardware, versi terakhirnya ada di sini. T: Apakah saya harus membenci dan menjelek-jelekkan Microsoft? ***J: Tidak perlu. Bukannya Microsoft itu menjijikkan, tapi sudah ada budaya hacker jauh sebelum Microsoft dan juga akan ada nanti setelah Microsoft menjadi sejarah. Energi yang Anda berikan untuk membenci Microsoft barangkali lebih baik dikerahkan untuk mencinpekerjaan Anda. Tulislah kode yang bagus — itu yang akan cukup menjelekkan Microsoft tanpa mengotori karma Anda. T: Tapi bukankan dengan software open-source programer tidak akan dapat memperoleh nafkah? J: Kemungkinan besar tidak — sejauh ini, industri software open-source justru menciptakan ketimbang menghilangkan lapangan pekerjaan. Jika ditulisnya suatu program akan menciptakan keuntungan bersih secara ekonomi, seorang programer tetap akan memperoleh bayaran terlepas dari apakah programnya itu akan menjadi program bebas atau tidak. Dan, terlepas dari sebanyak apa pun software “bebas” yang telah ditulis, selalu ada kebutuhan akan aplikasi yang baru dan dibuat sesuai pesanan. Di halaman web Open Source, saya menulis lebih jauh tentang hal ini. T: Bagaimana caranya mulai? Di mana saya bisa mendapatkan versi Unix bebas? J: Di bagian lain tulisan ini saya telah memberi petunjuk tempatnya. Untuk menjadi hacker Anda memerlukan motivasi dan inisiatif dan kemampuan untuk belajar mandiri. Mulailah sekarang… Footnote 1 Demigod, hacker yang telah memiliki pengalaman bertahun-tahun, memiliki reputasi kelas dunia, dan berperan penting dalam pengembangan rancangan, tool, atau game yang dipakai/dikenal oleh minimal separuh komunitas hacker (dari Jargon File 4.1.2). 2 Nerd, seseorang yang memiliki IQ di atas rata-rata,kurang mampu bercakap-cakap atau melakukan ritual sosial lainnya. (dari Jargon File 4.1.2).

 
Tinggalkan komentar

Ditulis oleh pada Juni 8, 2011 in bacaan, hacking, komputer, scurity

 

Pemuda Arab Vs Pendeta ….


Pemuda Arab Vs Pendeta …. oleh Ade Singh pada 04 Juni 2011 jam 1:03 Asalamualaikum Wr Wb Ada seorang pemuda arab yang baru saja menyelesaikan bangku kuliahnya di Amerika. Pemuda ini adalah salah seorang yang diberi nikmat oleh Allah berupa pendidikan agama Islam bahkan ia mampu mendalaminya. Selain belajar, ia juga seorang… juru dakwah Islam. Ketika berada di Amerika, ia berkenalan dengan salah seorang Nasrani. Hubungan mereka semakin akrab, dengan harapan semoga Allah SWT memberinya hidayah masuk Islam. Pada suatu hari mereka berdua berjalan-jalan di sebuah perkampungan di Amerika dan melintas di dekat sebuah gereja yang terdapat di kampung tersebut. Temannya itu meminta agar ia turut masuk ke dalam gereja. Mula mula ia keberatan, namun karena desakan akhirnya pemuda itu pun memenuhi permintaannya lalu ikut masuk ke dalam gereja dan duduk disalah satu bangku dengan hening, sebagaimana kebiasaan mereka. Ketika pendeta masuk, mereka serentak berdiri untuk memberikan penghormatan lantas kembali duduk. Di saat itu, si pendeta agak terbeliak ketika melihat kepada para hadirin dan berkata, “Di tengah kita ada seorang muslim. Aku harap ia keluar darisini.” Pemuda arab itu tidak bergerak dari tempatnya. Pendeta tersebut mengucapkan perkataan itu berkali-kali, namun ia tetap tidak bergerak dari tempatnya. Hingga akhirnya pendeta itu berkata, “Aku minta ia keluar dari sini dan aku menjamin keselamatannya. ” Barulah pemuda ini beranjak keluar. Di ambang pintu, pemuda bertanya kepada sang pendeta, “Bagaimana anda tahu bahwa saya seorang muslim.” Pendeta itu menjawab, “Dari tanda yang terdapat di wajahmu.” Kemudian ia beranjak hendak keluar. Namun, pendeta ingin memanfaatkan keberadaan pemuda ini dengan mengajukan beberapa pertanyaan, tujuannya untuk memalukan pemuda tersebut dan sekaligus mengukuhkan agamanya. Pemuda muslim itupun menerima tentangan debat tersebut. Pendeta berkata, “Aku akan mengajukan kepada anda 22 pertanyaan dan anda harus menjawabnya dengan tepat.” Si pemuda tersenyum dan berkata, “Silakan! Sang pendeta pun mulai bertanya: 1. Sebutkan satu yang tiada duanya, 2. dua yang tiada tiganya, 3. tiga yang tiada empatnya, 4. empat yang tiada limanya, 5. lima yang tiada enamnya, 6. enam yang tiada tujuhnya, 7. tujuh yang tiada delapannya, 8. delapan yang tiada sembilannya, 9. sembilan yang tiada sepuluhnya, 10. sesuatu yang tidak lebih dari sepuluh, 11. sebelas yang tiada dua belasnya, 12. dua belas yang tiada tiga belasnya, 13. tiga belas yang tiada empat belasnya. 14. Sebutkan sesuatu yang dapat bernafas namun tidak mempunyai ruh! 15. Apa yang dimaksud dengan kuburan berjalan membawa isinya? 16. Siapakah yang berdusta namun masuk ke dalam surga? 17. Sebutkan sesuatu yang diciptakan Allah namun Dia tidak menyukainya? 18. Sebutkan sesuatu yang diciptakan Allah dengan tanpa ayah dan ibu! 19. Siapakah yang tercipta dari api, siapakah yang diadzab dengan api dan siapakah yang terpelihara dari api? 20. Siapakah yang tercipta dari batu,siapakah yang diadzab dengan batu dan siapakah yang terpelihara dari batu? 21. Sebutkan sesuatu yang diciptakan Allah dan dianggap besar! 22. Pohon apakah yang mempunyai 12 ranting, setiap ranting mempunyai 30 daun, setiap daun mempunyai 5 buah, 3 di bawah naungan dan dua di bawah sinaran matahari?” Mendengar pertanyaan tersebut, pemuda itu tersenyum dengan keyakinan kepada Allah. Setelah membaca bismalah ia berkata: 1. Satu yang tiada duanya ialah Allah SWT. 2. Dua yang tiada tiganya ialah Malam dan Siang. Allah SWT berfirman, “Dan Kami jadikan malam dan siang sebagai dua tanda (kebesaran kami).” (Al-Isra’: 12). 3. Tiga yang tiada empatnya adalah kesilapan yang dilakukan Nabi Musa ketika Khidir menenggelamkan sampan, membunuh seorang anak kecil dan ketika menegakkan kembali dinding yang hampir roboh. 4. Empat yang tiada limanya adalah Taurat, Injil, Zabur dan al-Qur’an. 5. Lima yang tiada enamnya ialah Solat lima waktu. 6. Enam yang tiada tujuhnya ialah jumlah Hari ketika Allah SWT menciptakan makhluk. 7. Tujuh yang tiada delapannya ialah Langit yang tujuh lapis. Allah SWT berfirman, “Yang telah menciptakan tujuh langit berlapis-lapis. Kamu sekali-kali tidak melihat pada ciptaan Rabb Yang Maha Pemurah sesuatu yang tidak seimbang.” (Al-Mulk: 3). 8. Delapan yang tiada sembilannya ialah Malaikat pemikul Arsy ar-Rahman. Allah SWT berfirman, “Dan malaikat-malaikat berada di penjuru-penjuru langit. Dan pada hari itu delapan orang malaikat men-junjung ‘Arsy Rabbmu di atas (kepala) mereka.” (Al-Haqah: 17). 9. Sembilan yang tiada sepuluhnya adalah mu’jizat yang diberikan kepada Nabi Musa yaitu: tongkat, tangan yang bercahaya, angin topan, musim paceklik, katak, darah, kutu dan belalang. 10. Sesuatu yang tidak lebih dari sepuluh ialah Kebaikan. Allah SWT berfirman, “Barang siapa yang berbuat kebaikan maka untuknya sepuluh kali lipat.” (Al-An’am: 160). 11. Sebelas yang tiada dua belasnya ialah jumlah Saudara-Saudara Nabi Yusuf . 12. Dua belas yang tiada tiga belasnya ialah Mu’jizat Nabi Musa yang terdapat dalam firman Allah, “Dan (ingatlah) ketika Musa memohon air untuk kaumnya, lalu Kami berfirman, ‘Pukullah batu itu dengan tongkatmu.’ Lalu memancarlah daripadanya dua belas mata air.” (Al-Baqarah: 60). 13. Tiga belas yang tiada empat belasnya ialah jumlah Saudara Nabi Yusuf ditambah dengan ayah dan ibunya. 14. Adapun sesuatu yang bernafas namun tidak mempunyai ruh adalah waktu Subuh. Allah SWT ber-firman, “Dan waktu subuh apabila fajarnya mulai menyingsing.” (At-Takwir: 18). 15. Kuburan yang membawa isinya adalah Ikan yang menelan Nabi Yunus AS. 16. Mereka yang berdusta namun masuk ke dalam surga adalah saudara-saudara Nabi Yusuf , yakni ketika mereka berkata kepada ayahnya, “Wahai ayah kami,sesungguhnya kami pergi berlomba-lomba dan kami tinggalkan Yusuf di dekat barang-barang kami, lalu dia dimakan serigala.” Setelah kedustaan terungkap, Yusuf berkata kepada mereka, ” tak ada cercaan terhadap kamu semua.” Dan ayah mereka Ya’qub berkata, “Aku akan memohonkan ampun bagimu kepada Rabbku. Sesungguhnya Dia-lah Yang Maha Pengampun lagi Maha Penyayang.” (Yusuf:98) 17. Sesuatu yang diciptakan Allah namun tidak Dia sukai adalah suara Keledai. Allah SWT berfirman, “Sesungguhnya sejelek-jelek suara adalah suara keledai.” (Luqman: 19). 18. Makhluk yang diciptakan Allah tanpa bapa dan ibu adalah Nabi Adam, 19. Malaikat, Unta Nabi Shalih dan Kambing Nabi Ibrahim. Makhluk yang diciptakan dari api adalah Iblis, yang diadzab dengan api ialah Abu Jahal dan yang terpelihara dari api adalah Nabi Ibrahim. Allah SWT berfirman, “Wahai api dinginlah dan selamatkan Ibrahim.” (Al-Anbiya’:69). 20. Makhluk yang terbuat dari batu adalah Unta Nabi Shalih, yang diadzab dengan batu adalah tentara bergajah dan yang terpelihara dari batu adalah Ash-habul Kahfi (penghuni gua). 21. Sesuatu yang diciptakan Allah dan dianggap perkara besar adalah Tipu Daya wanita, sebagaimana firman Allah SWT “Sesungguhnya tipu daya kaum wanita itu sangatlah besar.” (Yusuf: 28). 22. Adapun pohon yang memiliki 12 ranting setiap ranting mempunyai 30 daun, setiap daun mempunyai 5 buah, 3 di bawah teduhan dan dua di bawah sinaran matahari maknanya: Pohon adalah Tahun, Ranting adalah Bulan, Daun adalah Hari dan Buahnya adalah Solat yang lima waktu, Tiga dikerjakan di malam hari dan Dua di siang hari. Pendeta dan para hadirin merasa takjub mendengar jawapan pemuda muslim tersebut. Kemudian ia pun mula hendak pergi. Namun ia mengurungkan niatnya dan meminta kepada pendeta agar menjawab satu pertanyaan saja. Permintaan ini disetujui oleh pendeta. Pemuda ini berkata, “Apakah kunci surga itu?” mendengar pertanyaan itu lidah pendeta menjadi kelu, hatinya diselimuti keraguan dan rupa wajahnya pun berubah. Ia berusaha menyembunyikan kekuatirannya, namun tidak berhasil. Orang-orang yang hadir di gereja itu terus mendesaknya agar menjawab pertanyaan tersebut, namun ia coba mengelak. Mereka berkata, “Anda telah melontarkan 22 pertanyaan kepadanya dan semuanya ia jawab, sementara ia hanya memberi cuma satu pertanyaan namun anda tidak mampu menjawabnya!” Pendeta tersebut berkata, “Sesungguh aku tahu jawaban nya, namun aku takut kalian marah.” Mereka menjawab, “Kami akan jamin keselamatan anda. ” Pendeta pun berkata, “Jawabannya ialah: Asyhadu An La Ilaha Illallah Wa Wa Aasyhadu Anna Muhammadar Rasulullah.” Lantas pendeta dan orang-orang yang hadir di gereja itu terus memeluk agama Islam. Sungguh Allah telah menganugerahkan kebaikan dan menjaga mereka dengan Islam melalui tangan seorang pemuda muslim yang bertakwa.

sumber http://www.facebook.com/notes/ade-singh/pemuda-arab-vs-pendeta-/214571478577581

 
1 Komentar

Ditulis oleh pada Juni 4, 2011 in bacaan

 

MikroTik Firewall


filter port virus

2000 Cracks 6776 TCP
Acid Battery 32418 TCP
Acid Battery 2000 52317 TCP
Acid Shivers 10520 TCP
Agent 31 31 TCP
Agent 40421 40421 TCP
Aim Spy 777 TCP
Ajan 25 TCP
Ambush 10666 UDP
AntiGen 25 TCP
AOL Trojan 30029 TCP
Attack FTP 666 TCP
Back Construction 666/5400/5401 TCP
Back Door Setup 5000/5001/7789 TCP
Back Orifice 31337/31338 UDP
Back Orifice 2000 8787/54320/54321 TCP
Back Orifice DLL 1349 UDP
BackDoor 1999 TCP
BackDoor-G 1243/6776 TCP
BackDoor-QE 10452 TCP
BackDoor-QO 3332 TCP
BackDoor-QR 12973/12975 TCP
BackFire 31337 UDP
Baron Night 31337 TCP
Big Gluck (TN) 34324 TCP
BioNet 12349 TCP
Bla 1042/20331 TCP
Black Construction 21 TCP
Blade Runner 21/5400-5402 TCP
BO client 31337 TCP
BO Facil 5556/5557/31337 TCP
Bo Wack 31336 TCP
BoBo 4321 TCP
BOWhack 31666 TCP
BrainSpy 10101 TCP
Bubbel 5000 TCP
BugBear 36794 TCP
Bugs 2115 TCP
Bunker-Hill 61348/61603/63485 TCP
Cain e Abel 666 TCP
Chargen 9 UDP
Chupacabra 20203 TCP
Coma 10607 TCP
Cyber Attacker 9876 TCP
Dark Shadow 911 TCP
Death 2 TCP
Deep Back Orifice 31338 UDP
Deep Throat 41/2140/3150/6771 TCP
Deep Throat v2 2140/3150/6670/6711/60000 TCP
Deep Throat v3 6674 TCP
DeepBO 31337 UDP
DeepThroat 999 TCP
Delta Source 26274 UDP
Delta Source 47262 UDP
Der Spacher 3 1000/1001/2000/2001 TCP
Devil 65000 TCP
Digital RootBeer 2600 TCP
DMsetup 58/59 TCP
DNS 53 TCP
Doly Trojan 21/1010-1012/1015 TCP
Donald Dick 23476/23477 TCP
DRAT 48/50 TCP
DUN Control 12623 UDP
Eclipse 2000 3459 TCP
Eclypse 3801 UDP
Email Password Sender 25 TCP
Evil FTP 23456 TCP
Executer 80 TCP
File Nail 4567 TCP
Firehotcker 79/5321 TCP
Fore 21/50766 TCP
FTP – Trojan 21 TCP
FTP99cmp 1492 TCP
Gaban Bus 12345/12346 TCP
Gate Crasher 6969/6970 TCP
GirlFriend 21554 TCP
Gjamer 12076 TCP
Hack ’99 KeyLogger 12223 TCP
Hack ‘a’ Tack 31780/31785/31787-31789 TCP
Hack ‘a’ Tack 31791/31792 UDP
HackCity Ripper Pro 2023 TCP
Hackers Paradise 31/456 TCP
HackOffice 8897 TCP
Haebu Coceda 25 TCP
Happy 99 25/119 TCP
Hidden Port 99 TCP
Hooker 80 TCP
Host Control 6669/11050 TCP
HVL Rat5 2283 TCP
icKiller 7789 TCP
ICQ (ICQ.com – community, people search and messaging service!) 1027/1029/1032 TCP
ICQ Revenge 16772/19864 TCP
ICQ Trojan 4590 TCP
Illusion Mailer 2155/5512 TCP
InCommand 9400 TCP
Indoctrination 6939 TCP
Infector 146 TCP
Infector 146 UDP
iNi-Killer 555/9989 TCP
Insane Network 2000 TCP
Invisible FTP 21 TCP
IRC-3 6969 TCP
JammerKillah 121 TCP
Kazimas 113/7000 TCP
Kuang2 25/17300/30999 TCP
Larva 21 TCP
Logged 20203 TCP
Masters’ Paradise 31/3129/40421-40423/40425-40426 TCP
Mavericks Matrix 1269 TCP
Millenium 20000-20001 TCP
MiniCommand 1050 TCP
Mosucker 16484 TCP
Nephron 17777 TCP
Net Administrator 21/555 TCP
Net Controller 123 TCP
Netbios datagram (DoS Attack) 138 TCP
Netbios name (DoS Attack) 137 TCP
Netbios session (DoS Attack) 139 TCP
NetBus 12345-12346 TCP
NetBus Pro 20034 TCP
NetMetropolitan 5031 TCP
NetMonitor 7300-7301/7306-7308 TCP
NetRaider 57341 TCP
NETrojan 1313 TCP
NetSphere 30100-30103 TCP
NetSpy 1024/1033/31338-31339 TCP
NewApt 25 TCP
NoBackO 1200-1201 UDP
One of the Last Trojan (OOTLT) 5011 TCP
OpC BO 1969 TCP
PC Crasher 5637-5638 TCP
Phase Zero 555 TCP
Phineas Phucker 2801 TCP
Pie Bill Gates 12345 TCP
Portal of Doom 3700/9872-9875 TCP
Portal of Doom 10067/10167 UDP
Priority 6969/16969 TCP
Progenic 11223 TCP
ProMail Trojan 25/110 TCP
Prosiak 22222/33333 TCP
Psyber Stream Server 1024/1170/1509/4000 TCP
Rasmin 531/1045 TCP
RAT 1095/1097-1099/2989 TCP
RC 65535 TCP
Rcon 8989 TCP
Remote Grab 7000 TCP
Remote Windows Shutdown 53001 TCP
RingZero 80/3128/8080 TCP
Robo-Hack 5569 TCP
Satanz backDoor 666 TCP
ScheduleAgent 6667 TCP
School Bus 54321 TCP
Schwindler 21554/50766 TCP
Secret Agent 11223 TCP
Secret Service 605/6272 TCP
Senna Spy FTP Server 21/11000/13000 TCP
ServeMe 5555 TCP
ServeU 666 TCP
Shadow Phyre 666 TCP
Shit Heep 6912 TCP
ShockRave 1981 TCP
Shtirlitz 25 TCP
Sivka-Burka 1600 TCP
SK Silencer 1001 TCP
Socket25 30303 TCP
Sockets de Troie 5000-5001/30303/50505 TCP
SoftWAR 1207 TCP
Spirit 2001a 33911 TCP
SpySender 1807 TCP
Stealth 25 TCP
Stealth Spy 555 TCP
Streaming Audio trojan 1170 TCP
Striker 2565 TCP
SubSeven 1243/2773/6711-6713/6776/7000/7215
/27374/27573/54283 TCP
SubSeven Apocalypse 1243 TCP
Syphillis 10086 TCP
Tapiras 25 TCP
TCP Wrappers 421 TCP
TeleCommando 61466 TCP
Terminator 25 TCP
Terror Trojan 3456 TCP
The Invasor 2140/3150 TCP
The Prayer 2716/9999 TCP
The Spy 40412 TCP
The Thing 6000/6400 TCP
The Traitor 65432 TCP
The Traitor 65432 UDP
The Trojan Cow 2001 TCP
The Unexplained 29891 UDP
Tiny Telnet Server 23/34324 TCP
TransScout 1999-2005/9878 TCP
Trinoo 34555/35555 UDP
Truva Atl 23 TCP
Ugly FTP 23456 TCP
Ultor’s Trojan 1234 TCP
Vampire 1020 TCP
Vampyre 6669 TCP
Virtual Hacking Machine 4242 TCP
Voice 1024/1170/4000 TCP
Voodoo Doll 1245 TCP
Wack-a-mole 12361-12362 TCP
Web Ex 21/1001 TCP
WhackJob 12631/23456 TCP
WinCrash 21/2583/3024/4092/5714/5741-5742 TCP
WinGate (socks-proxy) 1080 TCP
WinHole 1080/1082 TCP
WinNuke 135/139 TCP
WinPC 25 TCP
WinSatan 999 TCP
WinSpy 25 TCP
X-bill 12345-12346 TCP
Xplorer 2300 TCP
Xtcp 5550 TCP
Xtreme 1090 TCP
YAT 37651

Read the rest of this entry »

 

Drop bruteforce di mikrotik


Firewall rule untuk mencegah ssh bruteforce

 

/ip firewall filer
add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop \
comment="drop ssh brute forcers" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist \
address-list-timeout=10d comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 \
address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 \
action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list \
address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no


Firewall rule untuk mencegah FTP bruteforce

/ip firewall filer
add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop \
comment="drop ftp brute forcers"

add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m

add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect" \
address-list=ftp_blacklist address-list-timeout=3h


 

PCQ di MikroTik


PCQ (Per Connection Queue) dalam bahasa indonesianya "koneksi per jumlah antrian". 
maksudnya adalah membagi koneksi berdasarkan jumlah pengguna.
contoh:
kita memiliki bandwith sebesar 1M, jika jumlah pengguna = 1,
maka max bandwith yang diterima pengguna tersebut adalah full 1M.
jika pengguna = 2, maka maximal bandwith yang diterima masing-masing pengguna adalah 1M/2=512kbps dan begitu seterusnya
berikut contoh scriptnya.

/ip firewall mangle add chain=forward action=mark-connection new-connection-mark=penanda-koneksi

keterangan "firewall penanda koneksi"

/ip firewall mangle add chain=forward connection-mark=penanda-koneksi action=mark-packet new-packet-mark=penanda-paket 

keterangan "firewall penanda paket"

/queue type add name=pcq_unduh kind=pcq pcq-classifier=dst-address

keterangan "antrian unduh"

/queue type add name=pcq_unggah kind=pcq pcq-classifier=src-address

keterangan "antrian unggah"

/queue tree add parent=hotspot queue=pcq_unduh packet-mark=penanda-paket

keterangan "Membuat queue tree ke jaringan (hotspot)"

/queue tree add parent=ke-internet queue=pcq_unggah packet-mark=penanda-paket

keterangan "Membuat queue tree dari internet"

sumber (google) dan mikrotik official website
 

Tag: , , ,

TIPS interview


[TIPS] Pertanyaan yang Paling Sering Diajukan Saat Wawancara dan Jawabannya Pertanyaan² yang BIASANYA ditanyakan saat wawancara kerja:

1. Ceritakan tentang diri anda Ini pertanyaan yang PALING SERING ditanyakan saat interview dan paling sering dijawab dengan salah.

Contoh jawaban yg kurang tepat: Usia saya 21 tahun, lahir di Jogja, 1 Januari 1987. Anak ke 2 dari 5 bersaudara. Ayah saya pegawai negri, Ibu saya Ibu Rumah Tangga. Hobi saya jalan-jalan, nonton, dan baca komik.dst dst..

Yang tepat, jawablah dengan jawaban seputar your strengths and weaknesses point. Jangan cuma cerita yg bagus2 tentang diri loe karena nanti bisa dikira cuma talkin bullsh*t, ceritakan juga tentang kelemahan anda tapi dengan kemasan yang baik.

COntohnya:

Saya orang yang optimis, pekerja keras, kreatif, dan punya inisiatif tinggi. Saya mampu bekerja secara independent maupun bekerja sama dalam tim. Kadangkala saya suka lupa akan hal-hal kecil, tapi untuk menutupi kelemahan saya itu, saya selalu menyiapkan notepad kecil untuk mencatat segala hal agar tidak lupa. (ini kelemahan yg dikemas dengan baik).

2. Kenapa anda berhenti dari pekerjaan anda sebelumnya?

Jawab dengan positif. Jangan jelek²in perusahaan loe sebelumnya, apalagi ngomongin kejelekan bos/supervisor/temen kantor.

Jawab dengan senyuman dan katakan hal-hal positif seperti “mencari kesempatan yg lebih baik untuk berkembang”, “mencari tantangan baru”, dan sejenisnya.

3. Apa pengalaman anda di bidang ini? Kalo loe fresh graduate dan ngga punya pengalaman sama sekali, jawab aja dengan jujur. Tapi tambahkan statement bahwa loe adlh orang yang senang mempelajari hal-hal/tantangan baru dan seorang fast learner. Kalo loe ngga punya pengalaman di bidang itu (tp punya pengalaman di bidang lain), jawab aja senyambung mungkin.

Contoh: Loe ngelamar di bidang Marketing sementara pengalaman anda di Public Relation.

Jawab aja kalau loe punya basic excellent communication skill sewaktu bekerja sebagai PR yang pastinya merupakan modal untuk berinteraksi/communicate with customers.

4. APa yang anda ketahui tentang perusahaan ini?

Pertanyaan ini juga lumayan sering ditanyakan. That’s why sangat penting untuk melakukan background checking pada perusahaan yang loe lamar. Bergerak dibidang apakah perusahaan itu? Bagaimana pencapaiannya? Range Marketnya?, dll. Informasi tsb bisa didapatkan via internet, company website/profile, atau lebih bagus lagi dari “orang dalam” yg bekerja di perusahaan tsb.

5. Apakah anda sedang melamar di perusahaan lain selain disini?

Jawab dengan jujur, tp jangan bahas kelamaan. Tetap fokus pada interview loe yg skrg ini.

6. Kenapa anda ingin bekerja di perusahaan ini?

Jawaban atas pertanyaan ini harus dipikirkan dulu dan juga harus didasari oleh “background checking” yg sudah loe lakukan ttg perusahaan tsb. Ketulusan menjawab bakal keliatan banget di pertanyaan ini. So, jawablah dengan jawaban yg berhubungan dengan tujuan karir anda jangka panjang.

7. Apakah anda ada kenalan di perusahaan ini?

Hati-hati ngejawab yg satu ini. Pada beberapa perusahaan tertentu ada kebijakan-kebijakan mengenai hal ini. So, kalo memang lowongan tersebut loe ketahui dari teman/keluarga, tanyakan dulu kepada mereka mengenai kebijakan di perusahaannya.

8. Berapa gaji yang anda inginkan?

Hohohoho.. this is the ultimate question of all! Intinya disini: jangan gila! Jangan langsung jawab: “5juta pak, 10 juta pak!” Dan juga jangan malah malu-malu.. dan malah ngejawab “terserah bapak aja”.. Too Funny Yang bener, sebelom ngejawab tarik napas dulu sebentar (seolah-olah pura² mikir).. lalu nanya balik: “Maaf Pak, kalau boleh saya tahu, berapa range salary yang diberikan perusahaan ini untuk posisi ini?” “Kalo untuk posisi ini biasanya sekitar 2 sampai 2,5 juta” “Oh begitu. Begini Pak, kalau dari pihak saya, tentunya saya mengharapkan adanya peningkatan pendapatan dari pekerjaan saya yang sebelumnya.” “Memang sebelumnya salary anda berapa?” “(nah disinilah anda pasang ekspektasi gaji anda. Misalnya gaji anda sebelomnya 2jt, pastinya ngarepin lebih dong.. so mark-up sedikit jadi 2,5-3jt.. lebih boleh asal jangan gila) Kalo casenya si interviewer ngga ngasih tau range gajinya.. yah terpaksa loe harus kasih range gaji yg loe pengen. Untuk penetapan range ini, pertimbangkan segi biaya transportasi, uang makan, tunjangan kesehatan, gaji sebelumnya, job description nantinya, plus referensi dr temen²/kenalan loe yang bekerja di bidang yg sama.

9. APakah anda bisa bekerja dalam tim?

Selalu jawab IYA. This will add your plus points. Jangan lupa siapin examples kalo ditanya buktinya apa.

10. Jika anda diterima bekerja disini, berapa lama anda berencana untuk bekerja? Jangan pernah jawab spesifik: “Paling lama 2 taon aja Pak, soalnya blablablabl”. something like this should work: “Saya ingin bekerja untuk waktu yang lama. Atau selama kedua belah pihak merasa bahwa saya melakukan pekerjaan saya dengan baik”

11. Jelaskan mengapa perusahaan kami harus mempekerjakan anda? Jawab dengan semangat, percaya diri, dan antusias. Ini kesempatan bagus untuk “ngejual” diri anda. Katakan hal2 positif ttg diri loe yang dibutuhkan perusahaan/bisa menunjang kemajuan perusahaan. Berikan beberapa alasan termasuk skill, pengalaman, dan interest loe

12. Apa saja kekuatan diri anda? (Your greatest strength) Kuncinya tetap berpikiran positif.

Contoh2 yang bisa dipakai: kemampuan loe untuk me-manage skala prioritas, kemampuan loe untuk fokus pada pekerjaan, kemampuan loe untuk bekerja di bawah tekanan, kemampuan loe dalam pemecahan masalah, kemampuan loe dalam memimpin team, dll.

13. Apakah anda bersedia untuk bekerja lembur/bermalam/di akhir minggu?

Jawab sejujur-jujurnya

14. Apakah anda ada pertanyaan?

Selalu siapkan satu dua pertanyaan untuk menimbulkan kesan positif. Misalnya seperti seputar job description, ruang lingkup kerja, market perusahaan, dll. Berikut ini pertanyaan yang kadangkala keluar saat Interview:

1. Menurut anda, apakah anda termasuk orang sukses? Pertanyaan ini WAJIB dijawab IYA disertai dengan penjelasan singkat. Misalnya: “Saya punya target dan tujuan² dalam hidup, dan saat ini saya sudah berada di dalam jalur pencapaian tujuan² tersebut. I’m on the right track!”

2. Apa penilaian rekan kerja anda tentang anda?

Nah kalo yang ini jangan ngarang.. karena kalo yg interview loe seorang psikolog, bakal ketauan banget ngibulnya. That’s why sebaiknya loe pernah nanya sama rekan kerja mengenai hal ini. Ambil yang positif aja. COntohnya: “Teman saya di perusahaan saya yang sebelumnya selalu berkata bahwa saya adalah seseorang yang idealis dan perfeksionis dalam bekerja.”

3. Hal-hal apa yang anda lakukan selama setahun terakhir ini untuk meningkatkan kemampuan diri anda? Sebaiknya sih jangan ngarang karena nanti akan dituntut buktinya. Pertanyaan ini bisa dijawab seperti ini: “Saya mengikuti seminar A, training B, banyak membaca buku pengembangan diri, ikut kegiatan sosial, ikut organisasi, dll”

4. Apakah anda pernah di PHK? Jika tidak bilang tidak. Jika iya, jujur aja.. dan jawab dengan singkat tanpa ngejelek-jelekin perusahaan/mantan bos yg mem-PHK anda, dan juga jangan “menjatuhkan” citra diri loe secara terang2an.

5. Ceritakan mengenai pekerjaan impian anda Jangan jawab jenis pekerjaan secara spesifik. Lebih baik tetap bersikap “umum” dengan jawaban seperti: Pekerjaan yang saya cintai, atmosfir lingkungan kerja yang mendukung, pekerjaan dimana saya bisa menyalurkan kreatifitas dan inovasi saya, dst.” 6. Mana yang lebih penting: uang atau pekerjaan? Tidak ada jawaban yang lebih baik dari: “Uang selalu penting; tapi pekerjaan adalah yang terpenting” Yah meskipun rada-rada muna,.. but hey.. that’s how things work..

sumber kaskus.us

 
3 Komentar

Ditulis oleh pada Mei 2, 2011 in bacaan, tips dan trik

 

Menu Cairo Dock ala MacOSX di web


Assalamu`alaikum.

Akhir-akhir ini ga tau saya semakin tertarik dengan tampilan memukau dari MacOSX, mulai dari Desktop Ubuntu saya menggunakan tampilan ala MacOSX, MozillaFirefox MacOS Thems , sampai Menu web yang akan kita bahas berikut ini.

mungkin karena dipicu keinginan mempunyai Macbook keluaran Apple tapi ga kesampean?. yah ga apa-apa dah ga punya Macbook tapi bisa ngerasain tampilan Macbook dari ubuntu Thems 😀 jadi malu :(.. udah dlu curhatnya 😀

ok kita lanjut ke materi bahasan kita,

Sesuai dengan judul materi kita kali ini, yaitu membuat menu website ala cairodock milik MacOSX,

berikut screeenshotenya

Sepertinya Anda tidak asing lagi dengan tampilan diatas, jika anda adalah pengguna MacOS atau Linux yang menggunakan cairo dock. Read the rest of this entry »

 
2 Komentar

Ditulis oleh pada April 28, 2011 in programing, tips dan trik